[Python-Dev] Question regarding: Lib/_markupbase.py

Developer Developer just_another_developer at yahoo.de
Mon Feb 11 15:47:00 CET 2013

Same thing in the function: "_parse_doctype_attlist":

if ")" in rawdata[j:]:
    j = rawdata.find(")", j) + 1
    return -1

I would change it to:
pos = rawdata.find(")", j)
if pos != -1:
    j = pos + 1
    return -1

Best regards,

----- Ursprüngliche Message -----
Von: Fred Drake <fred at fdrake.net>
An: Developer Developer <just_another_developer at yahoo.de>
CC: "python-dev at python.org" <python-dev at python.org>
Gesendet: 15:10 Montag, 11.Februar 2013
Betreff: Re: [Python-Dev] Question regarding: Lib/_markupbase.py

On Mon, Feb 11, 2013 at 7:16 AM, Developer Developer
<just_another_developer at yahoo.de> wrote:
> Wouldn't it be better to do the following?
> Otherwise I think we are scanning rawdata[j:] twice.

Yes, that would be better, and avoids a string object creation as well.


Fred L. Drake, Jr.    <fred at fdrake.net>
"A storm broke loose in my mind."  --Albert Einstein

More information about the Python-Dev mailing list