[Python-Dev] cpython: Introduce importlib.util.ModuleManager which is a context manager to

Brett Cannon brett at python.org
Wed May 29 22:22:39 CEST 2013

On Wed, May 29, 2013 at 2:56 PM, R. David Murray <rdmurray at bitdance.com> wrote:
> On Wed, 29 May 2013 20:10:44 +0200, Antoine Pitrou <solipsis at pitrou.net> wrote:
>> On Wed, 29 May 2013 12:55:01 -0400
>> Brett Cannon <brett at python.org> wrote:
>> > > Perhaps 'managed_module'?
>> >
>> > managed_module is better than managed_initialization.
>> I don't understand how it's "managed". "manage", "manager", etc. is the
>> kind of dumb words everybody uses when they don't manage (!) to explain
>> what they're talking about.
>> My vote is for "module_to_init", "uninitialized_module",
>> "pristine_module", etc.

I don't like unititionalized_module or pristine_module as that isn't
guaranteed thanks to reloading; seems misleading.

> Actually, you are right, 'managed_module' isn't much if any better
> than those.
> Our problem is that there are two concepts we are trying to cram into
> one name: what the context manager is managing, and the object that the
> context manager gives you on entry to the with block.  There probably
> isn't a good answer.
> I suppose that one approach would be to have a module_initializer context
> manager return self and then separately call a method on it it to actually
> load the module inside the with body.  But adding more typing to solve
> a naming issue seems...odd.

That would make me feel icky, so I won't do it.

So module_to_init it is unless someone can convince me the bikeshed is
a different colour.

More information about the Python-Dev mailing list