[Python-Dev] PEP 451 update
ncoghlan at gmail.com
Sat Nov 2 16:38:48 CET 2013
On 3 November 2013 01:21, Brett Cannon <brett at python.org> wrote:
> On Sat, Nov 2, 2013 at 5:46 AM, Nick Coghlan <ncoghlan at gmail.com> wrote:
>> For the same reason, I also have a mild preference for "target" (or
>> the more explicit "load_target") as the name, although I won't object
>> if you and Brett prefer "existing".
> I would go with "module" or "target" and that is where I shall end the
I had a quick reread of the runpy docs:
I can definitely make "target" work (that's why I suggested it
originally, re-reading the docs just confirmed that), but I don't see
any non-confusing way to use "module".
Eric: since "target" was on both Brett's list and mine, it looks like
s/existing/target/ and clarifying that "incompatible target module"
should be reported by throwing ImportError from find_spec() will get
you the pronouncement you're looking for :)
Nick Coghlan | ncoghlan at gmail.com | Brisbane, Australia
More information about the Python-Dev