[Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

Glenn Linderman v+python at g.nevcal.com
Fri Oct 11 20:41:32 CEST 2013


On 10/11/2013 10:19 AM, Eric V. Smith wrote:
> On 10/11/2013 12:43 PM, Barry Warsaw wrote:
>> On Oct 11, 2013, at 06:27 PM, Georg Brandl wrote:
>>
>>> Maybe to fit in with other verb-like APIs used as context managers:
>>> it's open() not opened().
>> open() predates context managers, but maybe we need a new convention.
>>
>> with ignore(FileNotFoundError):
>>
>> vs
>>
>> with ignored(FileNotFoundError):
>>
>> To me anyway, the latter sounds better.
> I'm still -0, and maybe now -1 on the idea, mostly because it encourages
> an anti-pattern.
>
> But, to continue to paint the shed, shouldn't it be "ignoring", to match
> "closing"?

Seriously, "with" is the wrong spelling for this using.  It should be

while ignorning(FileNotFoundError)

Insistence on using "with" for the anti-pattern, and proper English, 
would require:

with ignorance_of(FileNotFoundError)

:)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-dev/attachments/20131011/dd5390ba/attachment.html>


More information about the Python-Dev mailing list