[Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

Ethan Furman ethan at stoneleaf.us
Thu Oct 17 18:05:48 CEST 2013


On 10/17/2013 08:26 AM, Nick Coghlan wrote:
>
>      # Arbitrarily nested search loop
>      with exit_label() as found:
>          for i in range(x):
>              for j in range(y):
>                  if matches(i, j):
>                      found.exit((i, j))
>      if found:
>          print(found.value)

+1 !


>          @property
>          def exc(self):
>              if self._exc is self._exc:

   typo


Thanks for this, I like it!  :)

--
~Ethan~


More information about the Python-Dev mailing list