[Python-Dev] PEP 450 adding statistics module
oscar.j.benjamin at gmail.com
Mon Sep 9 10:36:23 CEST 2013
On 9 September 2013 09:02, Serhiy Storchaka <storchaka at gmail.com> wrote:
> 08.09.13 20:52, Guido van Rossum написав(ла):
>> Well, to me zip(*x) is unnatural, and it's inefficient when the arrays are
> Perhaps we need zip.from_iterable()?
I would prefer it if chain.from_iterable were named something like
flatten (as it is in the itertools recipes). Similarly transpose is a
better name than zip.from_iterable.
More information about the Python-Dev