[Python-Dev] Add a "transformdict" to collections

Oscar Benjamin oscar.j.benjamin at gmail.com
Tue Sep 10 12:34:54 CEST 2013


On 10 September 2013 10:28, Antoine Pitrou <solipsis at pitrou.net> wrote:
> On the tracker issue, it seems everyone agreed on the principle. There
> is some bikeshedding left to do, though. So here are the reasonable
> naming proposals so far:
>
> - transformkeydict
> - coercekeydict
> - transformdict
> - coercedict
>
> I have a sweet spot for "transformdict" myself.

Could you not use a name with some sense of purpose like approxmatchdict?


Oscar


More information about the Python-Dev mailing list