[Python-Dev] Fwd: PEP 467: Minor API improvements for bytes & bytearray
ncoghlan at gmail.com
Mon Aug 18 01:12:39 CEST 2014
On 18 Aug 2014 08:55, "Barry Warsaw" <barry at python.org> wrote:
> On Aug 18, 2014, at 08:48 AM, Nick Coghlan wrote:
> >Calling it bytes is too confusing:
> > for x in bytes(data):
> > ...
> > for x in bytes(data).bytes()
> >When referring to bytes, which bytes do you mean, the builtin or the
> >iterbytes() isn't especially attractive as a method name, but it's far
> >explicit about its purpose.
> I don't know. How often do you really instantiate the bytes object there
> the for loop?
I'm talking more generally - do you *really* want to be explaining that
"bytes" behaves like a tuple of integers, while "bytes.bytes" behaves like
a tuple of bytes?
Namespaces are great and all, but using the same name for two different
concepts is still inherently confusing.
> Python-Dev mailing list
> Python-Dev at python.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Python-Dev