[Python-Dev] Common subset of python 2 and python 3

Nick Coghlan ncoghlan at gmail.com
Sun Jan 12 14:52:11 CET 2014


Hi Nachson,

Python 2.7 with the -3 warning flag covers most of this, while using tox to
run automated tests under both 2.x and 3.x should cover the rest (tox is
also useful for checking code runs under Python 2.6, even if you normally
use a newer version).

Is there anything in particular you feel isn't covered by the combination
of those two approaches?

Regards,
Nick.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-dev/attachments/20140112/af211086/attachment.html>


More information about the Python-Dev mailing list