[Python-Dev] Remaining decisions on PEP 471 -- os.scandir()

Nick Coghlan ncoghlan at gmail.com
Mon Jul 21 23:37:09 CEST 2014

On 22 Jul 2014 02:46, "Steve Dower" <Steve.Dower at microsoft.com> wrote:
> Personally I'd make it a string subclass and put one-shot properties on
it (i.e. call/cache stat() on first access where we don't already know the
answer), which I think is close enough to where it's landed that I'm happy.
(As far as bikeshedding goes, I prefer "_DirEntry" and no docs :) )

+1 for "_DirEntry" as the name in the implementation, and documenting its
behaviour under "scandir" rather than as a standalone object.

Only -0 for full documentation as a standalone class, though.


> Cheers,
> Steve
> _______________________________________________
> Python-Dev mailing list
> Python-Dev at python.org
> https://mail.python.org/mailman/listinfo/python-dev
> Unsubscribe:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-dev/attachments/20140722/ee899db9/attachment.html>

More information about the Python-Dev mailing list