[Python-Dev] PEP 471 -- os.scandir() function -- a better and faster directory iterator
ethan at stoneleaf.us
Fri Jun 27 01:43:43 CEST 2014
On 06/26/2014 04:36 PM, Tim Delaney wrote:
> On 27 June 2014 09:28, MRAB wrote:
>> Personally, I'd prefer the name 'iterdir' because it emphasises that
>> it's an iterator.
> Exactly what I was going to post (with the added note that thee's an obvious symmetry with listdir).
> +1 for iterdir rather than scandir
> Other than that:
> +1 for adding [it] to the stdlib
+1 for all of above
More information about the Python-Dev