[Python-Dev] PEP 471 -- os.scandir() function -- a better and faster directory iterator
steve at pearwood.info
Fri Jun 27 04:21:15 CEST 2014
On Thu, Jun 26, 2014 at 09:37:50PM -0400, Ben Hoyt wrote:
> I don't mind iterdir() and would take it :-), but I'll just say why I
> chose the name scandir() -- though it wasn't my suggestion originally:
> iterdir() sounds like just an iterator version of listdir(), kinda
> like keys() and iterkeys() in Python 2. Whereas in actual fact the
> return values are quite different (DirEntry objects vs strings), and
> so the name change reflects that difference a little.
I think that's a good objective reason to prefer scandir, which suits
me, because my subjective opinion is that "iterdir" is an inelegant
and less than attractive name.
More information about the Python-Dev