[Python-Dev] PEP 471 -- os.scandir() function -- a better and faster directory iterator
p.f.moore at gmail.com
Fri Jun 27 08:47:21 CEST 2014
On 26 June 2014 23:59, Ben Hoyt <benhoyt at gmail.com> wrote:
> Would love feedback on the PEP, but also of course on the proposal itself.
A solid +1 from me.
Some specific points:
- I'm in favour of it being in the os module. It's more discoverable
there, as well as the other reasons mentioned.
- I prefer scandir as the name, for the reason you gave (the output
isn't the same as an iterator version of listdir)
- I'm mildly against windows_wildcard (even though I'm a windows user)
- You mention the caching behaviour of DirEntry objects. The
limitations should be clearly covered in the final docs, as it's the
sort of thing people will get wrong otherwise.
More information about the Python-Dev