[Python-Dev] PEP 477: selected ensurepip backports for Python 2.7

Nick Coghlan ncoghlan at gmail.com
Thu Sep 4 06:18:08 CEST 2014


On 4 September 2014 12:21, Benjamin Peterson <benjamin at python.org> wrote:
> On Wed, Sep 3, 2014, at 17:03, Nick Coghlan wrote:
>> On 1 September 2014 08:00, Nick Coghlan <ncoghlan at gmail.com> wrote:
>> > Earlier versions of PEP 453 proposed bootstrapping pip into a Python 2.7
>> > maintenance release in addition to including it with Python 3.4.
>> >
>> > That part of the proposal proved to be controversial, so we dropped it from
>> > the original PEP in order to focus on meeting the Python 3.4 specific
>> > release deadlines. This also had the benefit of working out the kinks in the
>> > bootstrapping processing as part of the Python 3.4 release cycle.
>> >
>> > However, we still think we should start providing pip by default to Python
>> > 2.7 users as well, at least as part of the Windows and Mac OS X installers.
>>
>> I suggested off-list that, as Python 2.7 release manager, Benjamin
>> would be a good candidate for BDFL-Delegate for this proposal, and
>> both Guido and Benjamin agreed. The PEP has been updated accordingly:
>> http://hg.python.org/peps/rev/909954e4ba43 (I also fixed a
>> copy-and-paste error in the PEP status!)
>
> ... and accepted. Let's make our users' lives' better!.

Huzzah!

Over to you, Ned & Donald. We can give Steve the good news for the
Windows side of things as well :)

Cheers,
Nick.

-- 
Nick Coghlan   |   ncoghlan at gmail.com   |   Brisbane, Australia


More information about the Python-Dev mailing list