[Python-Dev] Undefined dlopen When Building Module On Android

Cyd Haselton chaselton at gmail.com
Mon Jan 19 15:51:58 CET 2015

I'm struggling with a build issue on Android; I've posted to the
general python list with no result, so I'm re-posting here in hopes
that someone can help.  If this is the wrong place feel free to let me

I'm attempting to build Python 2.7.8 on my Android device; I'm using
an environment that simulates a Linux filesystem within the Android
terminal using a port of fakechroot.  Within that environment I've
ported and/or bootstrapped a number of Linux utilities (curl, git,
openssl, gcc)

I run ./configure, then make, and the executable and library are
built.  The problem occurs when build_ext is run; the newly built
python executable builds, then links _struct, and immediately
afterwards I get an 'undefined reference to dlopen' error.

If I run ./python setup.py --verbose -library-dirs /path/to/lib
--libraries='c dl m' -f, the 'undefined reference to dlopen' error is
thrown again.

If I run ./python setup.py --verbose -library-dirs /path/to/lib
--libraries='-lc -ldl -lm' -f the build continues past _struct...even
though ld throws the expected 'unable to find -l-lc' and other errors.

Let me know if you need me to provide additional information.  Any
help would be greatly appreciated.


More information about the Python-Dev mailing list