[Python-Dev] Overriding stdlib http package

Donald Stufft donald at stufft.io
Sat Jan 24 16:21:19 CET 2015


> On Jan 24, 2015, at 10:17 AM, Donald Stufft <donald at stufft.io> wrote:
> 
> Or you have things like pdb++ which needs to replace the pdb import
> because a lot of tools only have a flag like —pdb and do not provide
> a way to switch it to a different import. The sys.path ordering means
> that pdb++ has to do hacks in its setup.py[1] which means it won’t be
> compatible with Wheel files or with a world where sdists don’t use
> a setup.py.

Sorry, forgot to link this https://bitbucket.org/antocuni/pdb/src/4669c3747a396e3766173feb40ebece32ab08aad/setup.py?at=default#cl-7

---
Donald Stufft
PGP: 7C6B 7C5D 5E2B 6356 A926 F04F 6E3C BCE9 3372 DCFA



More information about the Python-Dev mailing list