[Python-Dev] Bug in the DELETE statement in sqlite3 module

ninostephen mathew ninosm12 at gmail.com
Wed Jun 15 02:40:06 EDT 2016

Respected Developer(s),
while writing a database module for one of my applications in python I
encountered something interesting. I had a username and password field in
my table and only one entry which was  "Admin" and "password". While
debugging I purposefully deleted that record. Then I ran the same statement
again. To my surprise, it got execute. Then I ran the statement to delete
the user "admin" (lowercase 'a') which does not exist in the table.
Surprisingly again is got executed even though the table was empty. What I
expected was an error popping up. But nothing happened.  I hope this error
gets fixed soon. The code snippet is given below.

self.cursor.execute(''' DELETE FROM Users WHERE username =
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-dev/attachments/20160615/54140378/attachment.html>

More information about the Python-Dev mailing list