[Python-Dev] cpython: Uniformize argument names of "call" functions

Serhiy Storchaka storchaka at gmail.com
Wed Nov 30 04:01:21 EST 2016

On 29.11.16 19:58, victor.stinner wrote:
> https://hg.python.org/cpython/rev/7efddbf1aa70
> changeset:   105395:7efddbf1aa70
> user:        Victor Stinner <victor.stinner at gmail.com>
> date:        Tue Nov 29 18:47:56 2016 +0100
> summary:
>   Uniformize argument names of "call" functions
> * Callable object: callable, o, callable_object => func
> * Object for method calls: o => obj
> * Method name: name or nameid => method

This change looks wrong to me. "callable" and "callable_object" are 
better names for functions like PyObject_Call(), since it supports not 
just functions, but any callables. "name" is appropriate name of the 
parameter that denotes a method name, not a method object.

More information about the Python-Dev mailing list