[Python-Dev] PEP 563: Postponed Evaluation of Annotations

Guido van Rossum guido at python.org
Fri Nov 10 13:13:23 EST 2017

On Fri, Nov 10, 2017 at 9:50 AM, Ethan Furman <ethan at stoneleaf.us> wrote:

> On 11/10/2017 07:48 AM, Guido van Rossum wrote:
> I don't mind the long name. Of all the options so far I really only like
>> 'string_annotations' so let's go with that.
> As someone else mentioned, we have function annotations and variable
> annotations already, which makes string_annotations sound like it's
> annotations for strings.

We can't strive to encode the full documentation in the future's name.

> Contriwise, "annotation_strings" sounds like a different type of
> annotation -- they are now being stored as strings, instead of something
> else.

Trust me, that can also be misinterpreted. Let's stop the bikeshedding.

--Guido van Rossum (python.org/~guido)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-dev/attachments/20171110/416b7c77/attachment.html>

More information about the Python-Dev mailing list