[Python-Dev] Workflow blocked on the 3.6 because of AppVeyor; who owns the AppVeyor project?

Antoine Pitrou solipsis at pitrou.net
Wed Sep 5 07:22:01 EDT 2018

On Wed, 5 Sep 2018 11:03:48 +0100
Paul Moore <p.f.moore at gmail.com> wrote:

> On Wed, 5 Sep 2018 at 10:55, Victor Stinner <vstinner at redhat.com> wrote:
> >
> > Hi,
> >
> > It's no longer possible to merge any change in the 3.6 branch of
> > CPython, because the AppVeyor job fails:
> > https://bugs.python.org/issue34575
> >
> > It seems like AppVeyor has a build cache and this cache is outdated. I
> > tried to use the REST API but I'm not allowed to invalidate the cache:
> > even the most basic REST API query (list my own roles) fails with:
> >
> > {"message":"You do not have required permissions to perform this action."}
> >
> > Who ows the "python" AppVeyor project? Can someone please give me the
> > administrator permission on this project, so I will be able to invalid
> > the build cache?
> >
> > Moreover, would it be possible to give me the administrator permission
> > on the CPython GitHub project, so I would be able to mark the AppVeyor
> > as optional until the issue is solved (to unblock the workflow at
> > least)? I promise I will not mess up the Python project ;-)  
> I don't appear to have admin rights on Appveyor either. Also, there
> doesn't appear to be an appveyor.yml file in the CPython repository,
> so I'm not clear how the build process has been configured.

For some reason it seems to be located in a hidden directory
(".github/appveyor.yml").  Not the most intuitive decision IMHO.
Travis' own config file ".travis.yml" is still at repository root, which
makes things more confusing.



More information about the Python-Dev mailing list