[Python-Dev] Workflow blocked on the 3.6 because of AppVeyor; who owns the AppVeyor project?

Berker Peksağ berker.peksag at gmail.com
Wed Sep 5 09:08:05 EDT 2018

On Wed, Sep 5, 2018 at 12:55 PM Victor Stinner <vstinner at redhat.com> wrote:
> Hi,
> It's no longer possible to merge any change in the 3.6 branch of
> CPython, because the AppVeyor job fails:
> https://bugs.python.org/issue34575
> It seems like AppVeyor has a build cache and this cache is outdated. I
> tried to use the REST API but I'm not allowed to invalidate the cache:
> even the most basic REST API query (list my own roles) fails with:
> {"message":"You do not have required permissions to perform this action."}
> Who ows the "python" AppVeyor project? Can someone please give me the
> administrator permission on this project, so I will be able to invalid
> the build cache?
> Moreover, would it be possible to give me the administrator permission
> on the CPython GitHub project, so I would be able to mark the AppVeyor
> as optional until the issue is solved (to unblock the workflow at
> least)? I promise I will not mess up the Python project ;-)

I've just made the "continuous-integration/appveyor/pr" status check
optional on the 3.6 branch to unblock the development for now.

Indeed, AppVeyor's REST API doesn't work:

$ curl -H "Authorization: Bearer $APPVEYOR_TOKEN" -H "Content-Type:
application/json" -X DELETE
{"message":"You do not have required permissions to perform this action."}

I'm going to try to make you an admin on python/cpython, but I find
GitHub's user/team management UI a bit confusing, so no promise :)


More information about the Python-Dev mailing list