[Python-Dev] Feature request: Change a Dependency Package Version During Package Initiation

Q qiang.fang at zoho.com.cn
Fri May 17 04:00:11 EDT 2019


A lot of the Python code we use in production are used directly as imports in other python

distributions (such as the python comes with the finite element software Abaqus and MSC Marc), many

packages (such as matplotlib, numpy) that may have varying versioned dependencies.



I was wondering if this could be expanded to allow a version to be set within a package and have

that propagate to all modules in that package. For example in the root init.py if I set

multiversion(tornado, 2.2.1) then all modules in that package will use tornado 2.2.1 when I import

tornado.



See a relevant issue on github:

https://github.com/mitsuhiko/multiversion/issues/1



Thank you!

Qiang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-dev/attachments/20190517/fbe8ba07/attachment.html>


More information about the Python-Dev mailing list