<div class="gmail_quote">On Wed, Aug 19, 2009 at 2:20 PM, Eric Smith <span dir="ltr">&lt;<a href="mailto:eric@trueblade.com">eric@trueblade.com</a>&gt;</span> wrote:<br><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div class="im">I think using .network and .broadcast are pretty well understood to be the [0] and [-1] of the network address block. I don&#39;t think we want to start creating new terms or access patterns here.</div>
<br>
+1 on leaving .network and .broadcast as-is (including returning a IPvXAddress object).<br><font color="#888888">
</font></blockquote><div><br></div><div>-1.  I think &#39;network.number&#39; or &#39;network.zero&#39; is a lot clearer than &#39;network.network&#39;.  Maybe &#39;.broadcast&#39; would be okay, as long as it <i>can</i> be adjusted for those unusual, or maybe even only hypothetical, networks where it is not the [-1].</div>
<div><br></div></div>