<html><body><div style="font-family: times new roman, new york, times, serif; font-size: 12pt; color: #000000"><div><br></div><hr id="zwchr"><blockquote style="border-left:2px solid #1010FF;margin-left:5px;padding-left:5px;color:#000;font-weight:normal;font-style:normal;text-decoration:none;font-family:Helvetica,Arial,sans-serif;font-size:12pt;"><p dir="ltr"><br>
On 19 Sep 2014 17:38, "Bohuslav Kabrda" <<a href="mailto:bkabrda@redhat.com" target="_blank">bkabrda@redhat.com</a>> wrote:<br>
> - "Similarly, the more general python command should be installed whenever any version of Python is installed and should invoke the same version of Python as either python2 or python3."<br>
><br>
> The important word in the second point is, I think, *whenever*. Trying to apply these two points to Fedora 22 situation, I can think of several approaches:<br>
> - /usr/bin/python will always point to python3 (seems to go against the first mentioned PEP recommendation)<br>
> - /usr/bin/python will always point to python2 (seems to go against the second mentioned PEP recommendation, there is no /usr/bin/python if python2 is not installed)</p><p dir="ltr">I think this is what should happen, and the PEP is currently wrong. When writing the PEP, I don't think we accounted properly for the case where the "system Python" has migrated to Python 3, but the "default Python for end user scripts that don't specify otherwise" is still Python 2 (which is the migration strategy both Fedora and Ubuntu are adopting).</p></blockquote><div>Thanks, that was my thinking, too.<br></div><blockquote style="border-left:2px solid #1010FF;margin-left:5px;padding-left:5px;color:#000;font-weight:normal;font-style:normal;text-decoration:none;font-family:Helvetica,Arial,sans-serif;font-size:12pt;"><p dir="ltr">How does this sound as a possible revised recommendation (keep in mind I haven't checked this against the larger context yet):</p><p dir="ltr">"The more general python command should only be installed whenever the corresponding version of Python is installed (whether python2 or python3)."</p></blockquote><div>It seems to me that it is a bit unclear what "corresponding" is. Would it make sense to explicitly say that "python" command should be installed whenever the distro-chosen default system Python is installed?<br></div><blockquote style="border-left:2px solid #1010FF;margin-left:5px;padding-left:5px;color:#000;font-weight:normal;font-style:normal;text-decoration:none;font-family:Helvetica,Arial,sans-serif;font-size:12pt;"><p dir="ltr">Regards,<br>
Nick.<br></p></blockquote><div><br>Thanks a lot<br></div><div><br></div><div>-- <br></div><div><span name="x"></span>Regards,<br>Slavek Kabrda<span name="x"></span><br></div></div></body></html>