[Python-ideas] new pickle semantics/API

Collin Winter collinw at gmail.com
Thu Jan 25 23:22:19 CET 2007

On 1/25/07, tomer filiba <tomerfiliba at gmail.com> wrote:
> On 1/25/07, Josiah Carlson <jcarlson at uci.edu> wrote:
> > I believe the biggest problem with the proposal, as specified, is that
> > changing the semantics of __getstate__ and __setstate__ is a bad idea.
> > Add a new pair of methods and ask the twisted people what they think.
> > My only criticism will then be the strawman repr/unrepr.
> i'll try to come up with new names... but i don't have any ideas
> at the moment.

The "__getstate__" and "__setstate__" names don't really work for me
either, especially since __setstate__ creates a new object, as opposed
to changing the state of an existing object. Since this proposal is
all about simplification, how about something like "__simplify__" and
"__expand__", respectively?

Collin Winter

More information about the Python-ideas mailing list