[Python-ideas] new pickle semantics/API
tomerfiliba at gmail.com
Thu Jan 25 23:41:36 CET 2007
On 1/26/07, Collin Winter <collinw at gmail.com> wrote:
> The "__getstate__" and "__setstate__" names don't really work for me
> either, especially since __setstate__ creates a new object, as opposed
> to changing the state of an existing object. Since this proposal is
> all about simplification, how about something like "__simplify__" and
> "__expand__", respectively?
well, i like __simplify__, but __expand__ seems wrong to me.
some other suggestions i looked up:
__reconstruct__ (too long?)
__restore__ (but that's semantically the same as __setstate__)
i'd vote for __rebuild__. any other ideas?
More information about the Python-ideas