[Python-ideas] new pickle semantics/API

Collin Winter collinw at gmail.com
Fri Jan 26 00:02:26 CET 2007

On 1/25/07, tomer filiba <tomerfiliba at gmail.com> wrote:
> On 1/26/07, Collin Winter <collinw at gmail.com> wrote:
> > The "__getstate__" and "__setstate__" names don't really work for me
> > either, especially since __setstate__ creates a new object, as opposed
> > to changing the state of an existing object. Since this proposal is
> > all about simplification, how about something like "__simplify__" and
> > "__expand__", respectively?
> well, i like __simplify__, but __expand__ seems wrong to me.
> some other suggestions i looked up:
> __complicate__ (:-))
> __rebuild__
> __reconstruct__ (too long?)
> __restore__ (but that's semantically the same as __setstate__)
> i'd vote for __rebuild__. any other ideas?

I like __rebuild__.

Collin Winter

More information about the Python-ideas mailing list