[Python-ideas] [Web-SIG] Merge Cookie and cookielib?
adam at atlas.st
Wed Feb 6 00:39:17 CET 2008
(This is from a discussion taking place on Web-SIG, but this isn't web-
related, so I'm sending it to python-ideas.)
On 5 Feb 2008, at 18:21, Brett Cannon wrote:
> My current idea is the new names cookie.client and cookie.server for
> Cookie and cookielib, respectively. While this goes against the goal
> of making the new names easier to work with, Cookie has to be renamed
> because of its PEP 8 violation. And having cookie and cookielib in the
> stdlib will not help with differentiating between the two.
Has anyone proposed dropping the -lib suffix on *all* modules that
currently use it? It annoys me. It seems arbitrary and redundant.
I suppose there must be some historical reason for that, but I can't
imagine it would still be very relevant.
More information about the Python-ideas