[Python-ideas] [Web-SIG] Merge Cookie and cookielib?
santagada at gmail.com
Wed Feb 6 01:11:31 CET 2008
On 05/02/2008, at 21:39, Adam Atlas wrote:
> On 5 Feb 2008, at 18:21, Brett Cannon wrote:
>> My current idea is the new names cookie.client and cookie.server for
>> Cookie and cookielib, respectively. While this goes against the goal
>> of making the new names easier to work with, Cookie has to be renamed
>> because of its PEP 8 violation. And having cookie and cookielib in
>> stdlib will not help with differentiating between the two.
I like this, but maybe it goes against some notion of a shallow stdlib
namespace... so maybe cookieclient and cookieserver or something is
> Has anyone proposed dropping the -lib suffix on *all* modules that
> currently use it? It annoys me. It seems arbitrary and redundant.
how would you call httplib? httpclient I guess.
+50 if I could vote.
More information about the Python-ideas