[Python-ideas] Yet another alternative name for yield-from
Guido van Rossum
guido at python.org
Thu Apr 2 18:37:50 CEST 2009
On Wed, Apr 1, 2009 at 10:36 PM, Greg Ewing <greg.ewing at canterbury.ac.nz> wrote:
> Guido van Rossum wrote:
>>> y = gcall f(x)
>> Nice April Fool. :-)
> Actually, it wasn't meant to be -- it was a serious
> suggestion (it's not 1 April any more where I am).
> I suppose I'll have to post it again tomorrow
> before you'll believe that, though...
Well, no matter what, I think it's a bad name. Let's stick with 'yield
from'. I'm also returning to the view that return from a generator
used as a task (in Dave Beazley's terms) should be spelled differently
than a plain return. Phillip Eby's 'return from yield with' may be a
little long, but how about 'return from'?
--Guido van Rossum (home page: http://www.python.org/~guido/)
More information about the Python-ideas