[Python-ideas] Yet another alternative name for yield-from

Jacob Holm jh at improva.dk
Thu Apr 2 20:37:32 CEST 2009

Bruce Frederiksen wrote:
> Guido van Rossum wrote:
>> but how about 'return from'?
> or 'return finally'?(??) ...
Or what about "yield return"? That clearly marks the construct as 
belonging in a generator. It also mixes well with the idea of a "yield 
raise" that I mentioned in another mail (not a suggestion for this PEP).

- Jacob

More information about the Python-ideas mailing list