[Python-ideas] [Python-Dev] Set the namespace free!
Stephen J. Turnbull
stephen at xemacs.org
Tue Jul 27 03:43:22 CEST 2010
Georg Brandl writes:
> Am 26.07.2010 10:59, schrieb Anders Sandvig:
> > On Sat, Jul 24, 2010 at 3:31 AM, Gregory P. Smith <greg at krypto.org> wrote:
> >> Yuck. Anyone who feels they need a variable named the same a reserved word
> >> simply feels wrong and needs reeducation. [...]
> > While I agree with you in principle, I have been finding it
> > frustrating trying to calculate yield in my financial applications
> > lately... ;)
> In the spirit of optimistic programming, why not assume a large one
> and call it Yield? ;)
That's certainly more workable than the obvious near-synonym, "return".
More information about the Python-ideas