[Python-ideas] Bring back callable()

Benjamin Peterson benjamin at python.org
Wed Nov 24 04:02:11 CET 2010

Chris Rebert <pyideas at ...> writes:
> Perhaps it should also be renamed iscallable() for consistency with
> isinstance() and issubclass() and to free up the nice name "callable"
> for user use.

Let's not. We shouldn't make it anymore difficult to cope with having a gap of
no callable() by renaming it. Anyway, they're different kinds of words.
"instance()" or "subclass()" wouldn't make any sense.

More information about the Python-ideas mailing list