[Python-ideas] Add from __experimental__ import bla [was: Should we move to replace re with regex?]
Eric V. Smith
eric at trueblade.com
Wed Aug 31 23:36:21 CEST 2011
On 8/31/2011 3:44 PM, Brett Cannon wrote:
> On Wed, Aug 31, 2011 at 10:51, Guido van Rossum <guido at python.org> wrote:
>> On Wed, Aug 31, 2011 at 10:45 AM, Paul Moore <p.f.moore at gmail.com> wrote:
>>> On 31 August 2011 18:33, Antoine Pitrou <solipsis at pitrou.net> wrote:
>>>>> (*) Can we pick a terminology so we all agree that "3.3.3" is a "minor
>>>>> release", "3.3" is a "major release", and "3" an "earthshattering
>>>>> release"? Or other terms -- but something that is both agreed upon and
>>>>> clear enough without explanation. I'm tired of having to clarify minor
>>>>> and major every time I use them out of fear they'll be mistaken for
>>>>> "3" and "3.3".
>>>> +1! "Minor" really sounds like a misnomer when applied to feature
>>> How about 3.3.3 -> 3.3.4 is a "minor" release, 3.3 -> 3.4 is a
>>> "feature" release and 3 -> 4 is not something we generally talk about
>>> (or "compatibility-breaking" or something like that).
>>> I suspect that "minor" for changing the last digit is pretty
>>> comprehensible, it's using "major" for 3.3 that confuses people, so
>>> let's avoid that term...
>> Let's avoid minor and major altogether.
>> 2 -> 3: galactic release
>> 3.2 -> 3.3: feature release (also 3 -> 3.1)
>> 3.2.1 -> 3.2.2: bugfix release (also 3.2 -> 3.2.1)
> sys.version_info has already made the declaration of what each of the
> digits represent when it became a named tuple: major, minor, micro
> And if you don't like the naming, then blame me;
> http://bugs.python.org/issue4285 was the bug that led to the names and
> they are what I have always used for all software. After that blame
> Eric Smith for committing the patch. =)
Great. My fingerprints are on it.
More information about the Python-ideas