[Python-ideas] PEP 428: poll about the joining syntax

Steven D'Aprano steve at pearwood.info
Thu Oct 11 02:25:20 CEST 2012

On 11/10/12 06:07, Antoine Pitrou wrote:
> On Tue, 9 Oct 2012 00:45:41 +0530
> Nick Coghlan<ncoghlan at gmail.com>  wrote:
>> On Tue, Oct 9, 2012 at 12:24 AM, Guido van Rossum<guido at python.org>  wrote:
>>> I don't like any of those; I'd vote for another regular method, maybe
>>> p.pathjoin(q).
> [...]
>> I don't *love* joinpath as a name, I just don't actively dislike it
>> the way I do the four presented options (and it has the virtue of the
>> path.py precedent).
> How about one_path.to(other_path) ?


"To" implies to me either:

* one_path is mutated to become other_path; or

* you supply the end points, and the method finds a path between them

neither of which is remotely relevant. It certainly is not a synonym
for add/join/combine/concat paths. Brevity is not more important than


More information about the Python-ideas mailing list