[Python-ideas] Is there a good reason to use * for multiplication?

Greg Ewing greg.ewing at canterbury.ac.nz
Sun Oct 14 01:42:49 CEST 2012


Mike Meyer wrote:

> def __$<op>__(self, other, right): 
> 
> <op> must match a new grammer symbol "operator_symbol", with limits on
> it to for readability reasons: say at most three characters, all
> coming from an appropriate unicode class or classes

If it's restricted it to single Unicode character, we could
use its Unicode name as the method name:

def __CIRCLE_PLUS__(x, y):
    ...

-- 
Greg



More information about the Python-ideas mailing list