[Python-ideas] PEP 492 terminology - (native) coroutine objects
Ron Adam
ron3200 at gmail.com
Fri May 1 00:59:03 CEST 2015
On 04/30/2015 04:37 PM, Oscar Benjamin wrote:
> With PEP 492 it seems that I would get something like:
>
>>>> >>>async def af(): pass
>>>> >>>ag = af()
>>>> >>>ag
> <coroutine_object object af at 0x7fb81dadc828>
> It seems harder to think of a good name for ag though.
A waiter?
or awaiter?
As in a-wait-ing an awaiter.
Maybe there's a restaurant/food way of describing how it works. :-)
I'm not sure I have the use correct. But I think we need to use "await
af()" when calling an async function.
Cheers,
Ron
More information about the Python-ideas
mailing list