[Python-ideas] Changing the meaning of bool.__invert__

Steven D'Aprano steve at pearwood.info
Sat Apr 9 11:49:12 EDT 2016

On Sat, Apr 09, 2016 at 02:16:47PM +0300, Koos Zevenhoven wrote:

> Maybe the right warning type would be FutureWarning.

If we accept this proposal -- and I hope we don't -- I think that 
FutureWarning is the right one to use. It is what was used in 2.3 when 
the behaviour of ints changed as part of int/long unification.


More information about the Python-ideas mailing list