[Python-ideas] Unified style of cache management API
brett at python.org
Fri Mar 29 14:52:32 EDT 2019
On Thu, Mar 28, 2019 at 10:53 AM Serhiy Storchaka <storchaka at gmail.com>
> 28.03.19 19:45, Brett Cannon пише:
> > So I would say that a cache-clearing function convention would be a
> > reasonable starting point. If that turns out to not be enough for folks
> > we can talk about expanding it, but I think we should start small and
> > grow from there as needed.
> > So what name would people want. clear_cache() or _clear_cache()? I
> > personally prefer the latter since clearing the cache shouldn't be
> > something people should typically need to do and thus the function is an
> > implementation detail.
> This is an interesting idea. I think it should be a dunder name:
> __clearcache__() or __clear_cache__().
Between those two then I would go with __clearcache__(), but I was talking
about a naming scheme for a function in each module, not a new built-in in
case you thought I meant that.
> The disadvantage is that this method is slower in the case of large
> number of imported modules.
> Python-ideas mailing list
> Python-ideas at python.org
> Code of Conduct: http://python.org/psf/codeofconduct/
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Python-ideas