<p dir="ltr"><br>
On 18 Jun 2015 6:27 am, "Geoffrey Spear" <<a href="mailto:geoffspear@gmail.com">geoffspear@gmail.com</a>> wrote:<br>
><br>
><br>
><br>
> On Wed, Jun 17, 2015 at 3:36 PM, Joseph Jevnik <<a href="mailto:joejev@gmail.com">joejev@gmail.com</a>> wrote:<br>
>><br>
>> > In retrospect I wish this had been backported to 2.7, because they're super useful for making better APIs, but that ship has sailed<br>
>><br>
>> Why would this not be able to be ported now? It does not clash with any existing python 2 syntax so all current python 2 is still valid and has no behaviour change.<br>
>><br>
>><br>
><br>
> Python 2.7 is not getting new features (ssl changes notwithstanding), and there will never be a Python 2.8. There's certainly no desire to add new syntax so there would be code that will run in Python 2.7.11 only, and not in earlier 2.7 releases.</p>
<p dir="ltr">Exactly - it's only in truly exceptional cases like the PEP 466 & 476 network security changes that we'll add features to Python 2.7.</p>
<p dir="ltr">Keyword-only arguments are certainly a nice enhancement, but their absence isn't actively harmful the way the aging network security capabilities were.</p>
<p dir="ltr">Regards,<br>
Nick.</p>
<p dir="ltr">><br>
> _______________________________________________<br>
> Python-ideas mailing list<br>
> <a href="mailto:Python-ideas@python.org">Python-ideas@python.org</a><br>
> <a href="https://mail.python.org/mailman/listinfo/python-ideas">https://mail.python.org/mailman/listinfo/python-ideas</a><br>
> Code of Conduct: <a href="http://python.org/psf/codeofconduct/">http://python.org/psf/codeofconduct/</a><br>
</p>