Compiling woes on Solaris

Michael Ströder michael at stroeder.com
Mon May 14 16:44:09 CEST 2001


Since Brian did not re-post his question here I'll do it.

Ciao, Michael.

-------- Original Message --------
Subject: web2ldap feedback
Date: Fri, 27 Apr 2001 14:18:14 -0700
From: Brian Doherty <bdoherty at mailsvr.icon.palo-alto.med.va.gov>
To: feedback at web2ldap.de

[..]

I have the Netscape SDK in /usr/local/mozilla and the openldap v2 
in /usr/local.  Neither worked, and the ./Misc/openldap.sh didn't 
either.  I downloaded openldap 1.2.11 myself and installed it in 
/usr/local/openldap1.  Then I tried to configure python-ldap with 
./configure --with-ldap=/usr/local/openldap1 
This configured OK, but the make failed with the following: 

make[1]: Entering directory
`/usr/local/src/LDAP/Web/python-ldap-1.10alpha3/Modules'
gcc -shared  ./LDAPObject.o ./common.o ./constants.o ./errors.o
./functions.o ./ldapmodule.o ./message.o ./version.o ./linkedlist.o
./template.o ./CIDict.o  -L/usr/local/openldap1/lib -lldap -llber
-lsocket -lnsl -lm  -o ./_ldapmodule.so
Text relocation remains                         referenced
    against symbol                  offset      in file
<unknown>                           0x430      
/usr/local/openldap1/lib/libldap.a(getfilter.o)
<unknown>                           0x434      
/usr/local/openldap1/lib/libldap.a(getfilter.o)
<unknown>                           0x438      
/usr/local/openldap1/lib/libldap.a(getfilter.o)

... (many many many more lines like this)

ld: fatal: relocations remain against allocatable but non-writable
sections
collect2: ld returned 1 exit status
make[1]: *** [_ldapmodule.so] Error 1
make[1]: Leaving directory
`/usr/local/src/LDAP/Web/python-ldap-1.10alpha3/Modules'
make: *** [_ldapmodule-build] Error 2




More information about the python-ldap mailing list