latest ldap.i UPDATE!

Joe Little jlittle at
Wed May 30 04:30:23 CEST 2001

Ok.. stuck on windows box for network access, but here's the deal.

edit lber.i that I submitted, and comment out these function defs:


Next, edit Sascha's make file to explicitly include ldap50 and lber50 as
your included libraries. Last, make sure /opt/ldapsdk/lib or wherever
mozilla is in your LD_LIBRARY_PATH, and before any other ldap libs (like
Oracle, OpenLDAP, or the like)

I did a test ldapsearch with the test dir (its now,port)!!)
with the libraries and files present, and it all worked
fine against my openldap 2.0.x server. Yeah

Kudos to Michael for catching my not testing my latest lber.i file before
submitting to the list :)

On Mon, 28 May 2001, Michael Ströder wrote:

> Joe Little wrote:
> >
> > I've sent this to Sascha. It now contains the extended LDAP v3 API, with
> > only the netscape quasi-specific v3 extensions (server side sorts, and
> > other server or client side ops)
> >
> > build against Mozilla and openldap 2.x, but I need to check the openldap
> > 2.x again for some things. Still working..
> I tried to compile it against Netscape/Mozilla LDAP C SDK 5.0
> (binaries from Sun's web site downloaded today). After some tweaking
> of the Makefile (see attachment) it was built.
> But during import of ldapc it chokes with:
> Traceback (most recent call last):
>   File "tests/", line 9, in ?
>     import ldap
>   File "/home/michael/src/swig-ldap-0.17-stable-13/", line 2,
> in ?
>     import ldapc
> ImportError: undefined symbol: lber_debug
> Tried this again with OpenLDAP 2.0.11 libs. Same result.
> Ciao, Michael.

More information about the python-ldap mailing list