compiling against OpenLDAP 2.0.11

Joe Little jlittle at open-it.org
Sat Jun 16 02:25:32 CEST 2001


I answered this to Jens..

The problem is with the inclusion of ssl silently into MacOSX builds of 
OpenLDAP. He had to rebuild OpenLDAP --without-tls or to add -lssl to 
that lines.

second, its not a shared library, so you need to have _ldapmodule.so 
build with the libraries as objects (full path to libldap.a etc)

On Friday, June 15, 2001, at 05:16  PM, Daniel Schlenzig wrote:

> On Fri, Jun 15, 2001 at 11:29:57AM -0400, Jens Vagelpohl wrote:
>
>> a couple days ago there were some posts indicating that python-ldap 
>> does
>> indeed build against 2.0.11.
>>
>> i just tried building a python-ldap head CVS checkout against 2.0.11 
>> and
>> it stops with the well-known...
>>
>> <snip>
>> checking for library containing ber_free... -llber
>> checking for library containing ldap_open... no
>> checking for ldap_open... no
>> configure: error: Couldn't find LDAP library
>> </snip>
> When I first tried to compile python-ldap it behaved exactly like this.
> Actually I do have a workaround, but it is not anchored in the autoconf
> scripts, so you have to do it by hand.
>
> --- cut from the logs ---
>
> I startet vi on configure, skipped to line 1403 and replaced
>
> LIBS="$ac_func_search_save_LIBS"
>
> with
>
> LIBS="$ac_func_search_save_LIBS -lldap -lresolv"
>
> After rerunning configure and make everything worked as it should.
>
> --- cut ---
>
> This should do. libldap.so is after that recognized as "not needed", but
> do not worry about, because it still links correctly.
>
> bye, Daniel
>
> 


More information about the python-ldap mailing list