core dump / Objects/dictobject.c:471: bad argument to internal function

(::) Bob Ippolito bob at
Sun Jun 17 03:24:49 CEST 2001

I'm having a problem using python-ldap (redhat linux).

ActivePython 2.1, build 210
OpenLDAP 2.0.11

This is with the latest CVS version of python-ldap.. 1.10alpha3 wouldn't 
compile with OpenLDAP 2.0.11, I haven't found the patch to try it.

Any ideas?  I've tried using different values for bind and search, and it 
worked fine if I issued a search that doesn't have any results.. but any search 
that has results gets that dictobject error, or just core dumps!

(from the interpreter)

>>> import _ldap
>>> l.simple_bind_s("","")
>>> l.search_s("",0,"objectclass=*")
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
SystemError: Objects/dictobject.c:471: bad argument to internal function
>>> print l.result(3)
Segmentation fault (core dumped)

It's a weird install of redhat, and I haven't been using RPM's.. so I don't 
want to try one.  I just want to compile it myself and have it work.

(::) bob

More information about the python-ldap mailing list