Tagging the CVS archive

Steffen Ries steffen.ries at sympatico.ca
Mon Jul 16 15:32:03 CEST 2001


Konstantin Chuguev <Konstantin.Chuguev at dante.org.uk> writes:

...
> >     I would suggest a scheme where upper case tags are applied to
> >     releases, and lower case tags are branches.
> >
> >     e.g.:
> >     REL-1-10ALPHA3
> >     REL-1-11
> >     ...
> >     openldap-1-api
> >     ...
> >
> Are you sure the tags are case sensitive?

Yes.

> The other thing: I'd personally prefer (I'm not insisting though :-) "_"
> instead of "-".

Works for me too :-) (I was used to "." for separating parts of tags,
but this works with ClearCase, not with CVS, so I started to use -
instead...)

> In any case, if we're going to have branches dependant on the OpenLDAP
> API support, they could be called just OPENLDAP_1 or similar, while
> releases could be named REL_1_11 and REL_1_10.

I think it is better to have some naming convention which
distinguishes branches from releases. E.g. "openldap_1_branch".
 
> Unfortunately, I don't have enough experience in CVS to make branches.
> Could somebody do that?

cvs tag -b <branchname>
vs.
cvs tag <tagname>

I don't have access to CVS...

/steffen
-- 
steffen.ries at sympatico.ca	<> Gravity is a myth -- the Earth sucks!





More information about the python-ldap mailing list