Solaris 8 & python_ldap for Zope/Python

Joe Little jlittle at
Tue Jul 31 18:14:20 CEST 2001

Robert, as an addendum, the Solaris 8 libs aren't the netscape libs (Sun 
has their own working code base). So, alternatively, you could use the 
netscape libraries or the mozilla versions if the OpenLDAP ones do not 
work. Michael is correct in that any logs of the builds will help out 
list readers.

to the rest: yeah, I'm back in action, and happy to see a lot of list 
traffic of late in positive directions. It looks like I may get to focus 
most of my energies on Zope since the effort on the OpenLDAP 2.x stuff 
is progressing nicely. One note: I'm hoping to resolve darwin/MacOSX 
dynamic library issues since Zope folks seem to like MacOSX.

On Tuesday, July 31, 2001, at 08:49  AM, Michael Ströder wrote:

> Robert,
> sorry for answering so late.
> Robert Craven wrote:
>> Has anyone tried to get this to work?
>> Sorry if this has been covered, I am new to the list.  I am
>> trying to get Zope 2.4 + Python 2.1.1 + LDAP to work.
>> The LDAP libraries native to Solaris 8 seem to be missing a real
>> reference to ldap_name2template. At least that is what zope
>> complains about when it starts up.  I have the
>> python-ldap-1.10alpha3.  I have also tried to compile openldap
>> (versions 1.2.12 and 2.0.11) without any real success.
> I can't give you specific hints about building under Solaris 8 and
> the native LDAP libs with Solaris 8 (AFAIK it's the Netscape LDAP
> SDK).
> But I'd suggest that you check out the latest snapshot of
> python-ldap and try to build that against a local copy of the
> OpenLDAP 1.2.12 tree. Support for OpenLDAP 2 libs is work in
> progress and currently very experimental.
> If you have problems the most promising way is to come up with the
> build log on this mailing list.
> Ciao, Michael.

More information about the python-ldap mailing list