LDAP Adapter

Jens Vagelpohl jens at zope.com
Mon Mar 11 23:43:26 CET 2002

a simple test to see if the python-ldap module is at fault is::

- start the python interpreter
- type "import ldap"
- type "import _ldap"

if none of those give you tracebacks the python-ldap module is most likely 

did you know that when you go into the zope Control_Panel and click on 
"Products" you can actually see a traceback when you click on the broken 
product? this traceback would be helpful in diagnosing your problem.


On Monday, March 11, 2002, at 10:39 , Godwin Vaz wrote:

> Hi All,
> I am a newbie to linux and zope and have installed the the ldap adapter
> but as specified in the installation instructions have a broken product.
> I
> am using Red Hat 7.1 and Zope 2.4.3 rpm.
> I installed the python-ldapmodule-1.8-2.i386.rpm and have ended up with
> the ldapmodule.so in the following path
> /usr/lib/python1.5/site-packages/ldapmodule.so.
> after restarting zope i still have a broken product i guess it could be
> the ldapmodule.so creating the problem.
> After looking at the following site http://python-ldap.sourceforge.net/
> i am still not clear as to which programs or files i need to build the
> ldapmodule if that's what is causing the broken product.
> Could you please point me in the right direction.
> Your help is appreciated.
> Regards
> Godwin

More information about the python-ldap mailing list