python-ldap-2.0.0pre05 and zope

Michael Ströder michael at stroeder.com
Fri Jul 26 17:52:26 CEST 2002


mbagepll at memphis.edu wrote:
> 
> I am trying to install python-ldap module for zope 2.5.1 on solaris 8. 
> I am using netscape LDAP C library (there was no problem compiling it). 

Note that since LDAP C libs are diverging solely building against 
OpenLDAP 2.x libs is supported.

> ImportError: ld.so.1: /opt/local/web/zope/jed/bin/python: fatal: 
> libgcc_s.so.1: open failed: No such file or directory

No clue...

> And then, i invoked the zope python interpreter and tried to import 
> _ldap module. The error it throws is -
> 
>>>>import _ldap
>>>
> Traceback (most recent call last):
>   File "<stdin>", line 1, in ?
> ImportError: ld.so.1: /opt/local/web/zope/jed/bin/python: fatal: 
> relocation error: file /opt/local/web/zope/jed/lib/python2.1/site-
> packages/_ldap.so: symbol ldap_start_tls_s: referenced symbol not found

Although Netscape libs are not supported you could try to comment 
the line with HAVE_LDAP_START_TLS_S in setup.py. But don't waste 
too much time with it. I removed some code for old Netscape 3 API.
=> grab OpenLDAP 2.0.25 and compile the libs.

Ciao, Michael.






More information about the python-ldap mailing list