Patch to replace tuple() with tuple([])

Michael Ströder michael at
Fri Apr 11 13:36:27 CEST 2003

Peter Hawkins wrote:
 > Attached is a patch against 2.0.0pre07 which replaces instances of tuple()
 > with tuple([]). This is necessary since tuple() is not valid under
 > python 2.1.

Arrgh! Good catch!

Hmm, does (()) work under 2.1? Might be faster than tuple([]).

 > Could you please apply this? I realise that you may think python 2.1 is
 > old/deprecated, but it seems like not much work is required to keep it
 > functional for a little bit longer

I'm trying to support Python 2.0 or above. Not sure about 1.5.x though.

Ciao, Michael.

More information about the python-ldap mailing list