mandrake9.1 install problem

Michael Ströder michael at
Fri Apr 18 14:18:26 CEST 2003

Alain Soyeur wrote:
 > I used python-ldap without problems

Which version?

> warning: build_py: file Lib/ (for module ldap) not found
> warning: build_py: file Lib/ldap/ (for module ldap.schema) not found

These two messages are no problem. It's just an issue with the DistUtils not 
properly recognizing the module packages.

> I tried an install with python install, but when I use my old 
> scripts, they don't work anymore, with errors like :
> NameError: global name 'SCOPE_SUBTREE' is not defined

Please try the following:

$ python -c "import ldap; print ldap.SCOPE_SUBTREE"

Ciao, Michael.

More information about the python-ldap mailing list